1004 Counting Leaves (30分) [深度优先搜索]

1004 Counting Leaves (30分) [深度优先搜索]

题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
题目大意

找出家族中的没有生宝宝的家庭成员。
第一行输入为两个数字,第一个为家族系谱图中的总结点数N,第二个为非叶子结点的数量M。
接下去给出M行,每一行的输入给是为,一个非叶子结点的ID(由两位数组成),他的孩子数量,他的孩子的ID(由两位数组成);
题目将根结点的ID固定为01。输出为家族系谱图中的每一层叶子结点的数量,即现实生活中每一辈没有养育孩子的人的数量。

题目分析

利用二维容器构建家族系谱图,将每一个结点在孩子结点压入这个结点的空间,之后从根结点开始对数进行深度优先遍历。如果该结点,利用递归的思想对孩子结点再进行深度优先搜索;如果该结点为叶子结点,则将该层的叶子结点数量++,同时判断家族系谱图的最大层数有没有增加,如果增加了则对其进行替换,最后对结果进行输出。

代码
#include "iostream"
#include "stdio.h"
#include "vector"
using namespace std;
int num[105];
int maxlevel = 0;
vector<int> a[105];//二维的向量

void dfs(int index,int level){
    if (a[index].size() == 0){//判断结点为叶子结点,则num++;
        num[level]++;
        if (maxlevel < level){
            maxlevel = level;
        }//如果当前所在的层数大于max层,将max层替换为当前层,即统计家族系谱图总共有几层。
        return ;
    }
    if (a[index].size() != 0){//判断结点不是叶子,对于他的孩子同样进行dfs搜索。
        for (int i = 0;i < a[index].size();i++){
            dfs(a[index][i], level+1);
        }
    }
}

int main(){
    int N,K;
    int t1,t2,t3;
    scanf("%d%d",&N,&K);//输入总数量已经非叶子结点的数量
    for (int i = 0;i < K;i++){
        scanf("%d%d",&t1,&t2);
        for (int j = 0;j < t2;j++){
            scanf("%d",&t3);
            a[t1].push_back(t3);//在t1中压入他的孩子信息。
        }
    }
    for (int i = 0;i < 105;i++){
        num[i] = 0;//初始化每一层的叶子结点数量为0。
    }
    dfs(1,0);//深度优先搜索找出每一层的叶子结点数量。
    for (int i = 0;i <= maxlevel;i++)
    {
        if (i != maxlevel) printf("%d ",num[i]);
        else printf("%d\n",num[i]);//输出每一层的结果。
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值