PAT甲级 1001 A+B Format题解

1001 A+B Format (20 ) [简单处理数据]

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
题目大意

计算a+b并以特定的格式输出a+b的结果。
规范格式为每三个数字分为一组以逗号隔开。
输入两个大小大于 −106小于106的数字,输出结果。

题目分析

题目主要涉及对与输出结果的处理,结果分为等于零,小于零,大于零三种情况。对于等于零的情况直接输出0,对于等于零的情况需要在输出前先输出一个符号,大于零的情况正常处理。将输出结果以三个为一组存储到数组里,再依次序输出。

代码
#include "stdio.h"
int main(){
    int a,b,sum1,sum2;
    int c[1000000];//用于存放每组数据
    int i;
    scanf("%d%d",&a,&b);
    sum1 = a+b;
    if (sum1 == 0)
    {
        printf("%d",sum1);
        return 0;
    }//如果等于零直接输出结果。
    if (sum1<0)
    sum1 = -sum1;//小于零,先将其取反,最后在输出时提前输出负号。
    sum2 = a+b;
    for (i = 0;sum1 != 0;i++)
    {
        c[i] = sum1%1000;
        sum1 = sum1/1000;
    }//每三个数字一组,放入数组。
    i = i-1;
    if(sum2<0) printf("-");
    printf("%d",c[i]);
   if (i > 0) printf(",");
    for (i = i-1;i >= 0;i--){
        printf("%03d",c[i]);
        if (i != 0) printf(",");
    }
      printf("\n");
      return 0;
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值