React中使用antd报错:TypeError: antd__WEBPACK_IMPORTED_MODULE_1__.Form.create(...) is not a function

问题描述:

最近在学着使用antd的表单组件,刚开始写就给我报错,疯了

报出以下错误:

报的错就尼玛离谱,在网上搜了,说是antd的版本不对,让换3.X的版本

然后就换呗,到antd官网看了下有什么3.X的版本,安装好之后,又报错了

错误信息如下:

 

这个时候我才意识到原来是我函数给拼错了

为什么一开始不报这个错?VS也顺利通过编译,明明使用了函数还没有定义不知道为什么就给编译通过了,平时有一点点无关痛痒的错误就报得和天塌下来一样。真真是迷惑行为

 

问题解决:

 

1、看是不是antd版本的问题

 

2、如果排除版本以及编写逻辑都正确,一定要去检查一下单词是否拼错、大小写问题等不容易被发现的细节

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页