17年冬季第一题 PAT甲级 1140 Look-and-say Sequence (20分)

本文介绍了Look-and-say序列的概念,它是一种基于前一个数字描述生成下一个数字的序列。例如,从一个数字开始,第n+1个数字描述了第n个数字的组成。给定一个数字和一个正整数N,任务是计算该数字的Look-and-say序列的第N项。输入包含一个数字和一个正整数N,输出是序列的第N项。注意,序列生成时要按look-and-say原则就地处理,而非统计全局计数。
摘要由CSDN通过智能技术生成

原题

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

易错点

生成的序列并不是统计全局的计数,而是look and say,就地处理。

代码

#include<iostream>
#include<vector>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
    int d,n;
    cin>>d>>n;
    string s=to_string(d);
    for(int i=0;i<n-1;i++){
        int len=s.size(),same=1;
        string t="";
        for(int j=0;j<len;j++){
            if(j+1<len){
                if(s[j]==s[j+1]){
                    same++;
                }else {
                    t+=s[j];
                    t+=to_string(same);
                    same=1;
                }
            }else {
                t+=s[j];
                t+=to_string(same);
            }
            
        }
        s=t;

    }
    cout<<s<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值