Hdu 3507 Print Article (线性DP)

Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤  500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
  
  
5 5 5 9 5 7 5
 

Sample Output
  
  
230
 

Author
Xnozero
 
题意略;
思路:本题是比较基本的线性规划
状态转移方程为: dp[i] = min(dp[j] + (sum[i]-sum[j])^2 + m) (j < i);
性质类似于四边形不等式
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define hehe cout<<"shabi"<<endl

long long dp[500010],sum[500010];

int m,n,s[500010],date;
void dpe()
{
    long long temp;
    dp[0]=0;
    s[0]=0;
    for (int i=1;i<=n;i++)
    {
        dp[i]=1e18;
        for (int j=s[i-1];j<=i;j++)
        {
            temp=dp[j]+(sum[i]-sum[j])*(sum[i]-sum[j])+m;
            if(dp[i]>=temp)
            {
                s[i]=j;
                dp[i]=temp;
            }
        }
    }
}
int main ()
{
    //freopen ("out.txt","r",stdin);
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        memset(s,0,sizeof(s));
        for (int i=1;i<=n;i++) {
            scanf ("%d",&date);
            sum[i]=sum[i-1]+date;
        }
        dpe();
        printf("%lld\n",dp[n]);
    }
    
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值