hdu 3507 Print Article(DP+斜率优化)

Print Article

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2390    Accepted Submission(s): 790


Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤  500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
  
  
5 5 5 9 5 7 5
 

Sample Output
  
  
230
 

Author
Xnozero
 

Source
 

Recommend
zhengfeng
 

题目:http://acm.hdu.edu.cn/showproblem.php?pid=3507

题意:给你n个单词,要你决定一个排版的策略使得花费最小,花费的公式在上面

分析:很容易的一道题,写出简单的转移

f[ i ]=min{ f[ j-1 ] +w[ j , i ] + m} (1<=j<=i)

w[ j , i ]=sum{ c[ j ] + c[ j+1 ] +... +c[ i ] }

设:s[ i ]=sum{ c[ 1 ] + c[ 2 ]+...  + c[ i ] }

综上可以得到

f[ i ]=min{ f[ j-1 ]+s[ j-1 ]^2 -2 s[ i ]*s[ j-1 ] }+s[ i ]^2+m

令 a=2s[ i ]   x=s[ j- 1]    y= f[ j-1 ]+s[ j-1 ]^2

G=-ax+y

即y=ax+G,很明显的斜率优化了。。。

这题丝毫没有坑人的地方吧,1Y了

代码:

#include<cstdio>
#include<iostream>
using namespace std;
const int mm=555555;
int f[mm],s[mm],q[mm];
int i,j,n,m,l,r;
bool TRight(int ax,int ay,int bx,int by,int cx,int cy)
{
    return (ax-bx)*(cy-by)>=(ay-by)*(cx-bx);
}
int gx(int i)
{
    return s[i-1];
}
int gy(int i)
{
    return f[i-1]+s[i-1]*s[i-1];
}
int get(int i,int a)
{
    return gy(i)-a*gx(i);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        f[0]=s[0]=l=0,r=-1;
        for(i=1;i<=n;++i)
        {
            scanf("%d",&s[i]);
            s[i]+=s[i-1];
        }
        for(i=1;i<=n;++i)
        {
            while(l<r&&TRight(gx(q[r-1]),gy(q[r-1]),gx(q[r]),gy(q[r]),gx(i),gy(i)))--r;
            q[++r]=i;
            while(l<r&&get(q[l],2*s[i])>=get(q[l+1],2*s[i]))++l;
            f[i]=get(q[l],2*s[i])+m+s[i]*s[i];
        }
        printf("%d\n",f[n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值