P1001 A+B Format
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106 . The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
题解
简单题,直接转化成字符串再分割一下
#include <iostream>
int main() {
long long a, b;
std::cin >> a >> b;
long long c = a + b;
if (c < 0) {
std::cout << '-';
c = -c;
}
auto str = std::to_string(c);
auto len = str.length();
auto pt = (len) % 3;
for (int i = 0; i < pt; i ++