PAT 甲级 1001 1004 题解

博客详细解析了PAT甲级编程竞赛中的两道题目——P1001 A+B Format和P1004 Counting Leaves。P1001要求计算两个整数的和,并以标准格式输出,例如使用逗号分隔每三个数字。P1004涉及家族树的构建,目的是统计每个层次没有子节点的家庭成员数量。题解提供了输入输出规范及样例,并给出了问题的解决方案思路。
摘要由CSDN通过智能技术生成

P1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106 . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题解

简单题,直接转化成字符串再分割一下

#include <iostream>

int main() {
   
    long long a, b;
    std::cin >> a >> b;
    long long c = a + b;
    if (c < 0) {
   
        std::cout << '-';
        c = -c;
    }
    auto str = std::to_string(c);
    auto len = str.length();
    auto pt = (len) % 3;
    for (int i = 0; i < pt; i ++
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值