微软2016春招笔试题1

平台:gcc

全新的网站Hihocoder,很有意思的网站哈哈~接到微软的笔试通知,所以就好好准备吧~四个编程题~简单粗暴我喜欢~

但貌似微软并没有说考试期间要设置摄像头或者是不能用本地编译器

忐忑中,要去问问贴吧一起考试的小伙伴了~


今天尝试着写了今年春招的第一题,从读题到写完大概花了一个多小时~o( ̄ヘ ̄o#) 

#1288 : Font Size

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.


For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10
样例输出
3
2

#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
	int i,num,N,P,W,H;
	int a[1000];
	scanf("%d",&num);
	while(num--)
	{
	   scanf("%d %d %d %d",&N,&P,&W,&H);
		for( i=0;i<N;i++)
		{
			scanf("%d",&a[i]);
		}
		int S=1;
		while(S++)
		{
		  int y=0;int k=W/S;int z=H/S;
		  if(k==0||z==0) break;
			for(i=0;i<N;i++)
			{
				if(a[i]%k==0)
					y=y+a[i]/k;
				else y=y+a[i]/k+1;
			}
			int M=ceil(y/z);
		if(M<=P)
			  continue;
		 else
		  break;
		}		  
		printf("%d\n",S-1);
	}
   
   return 0;
}
   


学到的东西:

1 关于向上取整和向下取整,头文件是math.h,函数分别为 ceil和floor  floor可以直接用除法代替,不过要注意有的程序两种混着用

2 gcc编译器warning:‘for’ loop initial declarations are only allowed in C99 mode, 解决办法:将 for 里面的i 声明放在loop外面

3 这个方法其实很蠢。。。从一找到最后。。。有更多的好办法欢迎大家留言~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值