1147 Heaps-PAT甲级

本文探讨了完全二叉树的性质,特别是在层次遍历序列下如何判断其是否构成最大堆或最小堆,以及如何根据层次遍历序列输出后序遍历序列。通过实例演示了如何使用数组坐标定位子节点,进行堆属性检查,并提供了实现这一过程的C++代码。
摘要由CSDN通过智能技术生成

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

给出一个完全二叉树的层次遍历序列,判断该二叉树是什么顶堆以及根据其层次遍历的序列输出该二叉树的后序遍历的序列。

解题思路:由于该树为完全二叉树,故可以直接利用数组的坐标来寻找其左子树与右子树,根结点的下标为root,下标从1开始,判断2*root左子树以及2*root+1右子树与根结点的关系,最后也是根据数组下标的关系输出后序遍历的顺序即可。

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=1005;
int tree[N];
int m,n;
int bigflag,smallflag,flag;
bool check(){
	for(int i=1;i<=n/2;i++){
		if(2*i<=n){
			if(tree[i]>=tree[2*i]){
				bigflag=1;
			}else{
				smallflag=1;
			}
		}
		if((2*i+1)<=n){
			if(tree[i]>=tree[2*i+1]){
				bigflag=1;
			}else{
				smallflag=1;
			}
		}
	}
}
void postorder(int root){
	if(root>n){
		return;
	}
	postorder(2*root);
	postorder(2*root+1);
	if(flag) printf(" ");
	printf("%d",tree[root]);
	flag=1;
	
}
int main(){
	scanf("%d%d",&m,&n);
	for(int i=1;i<=m;i++){
		bigflag=0;//初始化为0 
		smallflag=0;
		flag=0;
		for(int j=1;j<=n;j++){
			scanf("%d",&tree[j]);
		}
		check();
		if(bigflag==1&&smallflag==1){
			printf("Not Heap\n");
		}else if(bigflag==1){
			printf("Max Heap\n");
		}else{
			printf("Min Heap\n");
		}
		postorder(1);
		printf("\n");
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值