ZOJ3911 Prime Query(线段树区间修改+单点更新)

Prime Query


Time Limit: 5 Seconds      Memory Limit: 196608 KB


You are given a simple task. Given a sequence A[i] with N numbers. You have to perform Q operations on the given sequence.

Here are the operations:

 

  • A v l, add the value v to element with index l.(1<=V<=1000)
  • R a l r, replace all the elements of sequence with index i(l<=i<= r) with a(1<=a<=10^6) .
  • Q l r, print the number of elements with index i(l<=i<=r) and A[i] is a prime number

 

Note that no number in sequence ever will exceed 10^7.

Input

The first line is a signer integer T which is the number of test cases.

For each test case, The first line contains two numbers N and Q (1 <= N, Q <= 100000) - the number of elements in sequence and the number of queries.

The second line contains N numbers - the elements of the sequence.

In next Q lines, each line contains an operation to be performed on the sequence.

Output

For each test case and each query,print the answer in one line.

Sample Input

1
5 10
1 2 3 4 5
A 3 1      
Q 1 3
R 5 2 4
A 1 1
Q 1 1
Q 1 2
Q 1 4
A 3 5
Q 5 5
Q 1 5

Sample Output

2
1
2
4
0
4

Author: HUA, Yiwei
Source: ZOJ Monthly, October 2015
 

 

一、原题地址

点我传送

 

二、大致题意

有三种操作;

1、给某个单点加上v

2、将区间[ l, r ]替换成v

3、查询区间[l, r ]内有多少个素数。

 

三、思路

都是一些线段树的基本操作,关键在于判断素数需要先打出素数表。

 

四、代码

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cmath>
#include<iostream>
#include<deque>
#include<map>
#include<stack>
#include<set>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;


const int MAXN = 1e7+5;
int Mark[MAXN];
int prime[MAXN];
int Prime()
{
	int tot = 0;
	memset(Mark, 0, sizeof(Mark));
	Mark[0] = 1; Mark[1] = 1;
	for (int i = 2; i < MAXN; i++)
	{
		if (Mark[i] == 0) {
			prime[tot++] = i;
		}
		for (int j = 0; j < tot && prime[j] * i < MAXN; j++)
		{
			Mark[i * prime[j]] = 1;
			if (i % prime[j] == 0) {
				break;
			}
		}
	}
	return tot;
}


const int N = 100005;
LL a[N];
LL  lazy[N << 2];
int n, q;
struct Tree
{
	int l, r;
	LL sum;
	LL realNum;
	int mid()
	{
		return (l + r) >> 1;
	}
}tree[N<<2];

void PushUp(int rt)
{
	tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
}

void PushDown(int rt,int m)
{
    if (lazy[rt])
    {
        lazy[rt << 1] = lazy[rt];
        lazy[rt << 1 | 1] = lazy[rt];
        if(!Mark[lazy[rt] ])
        {
            tree[rt << 1].sum =(m - (m >> 1));
            tree[rt << 1 | 1].sum = (m >> 1);
        }
        else
        {
            tree[rt << 1].sum =0;
            tree[rt << 1 | 1].sum =0;
        }
        tree[rt << 1].realNum=lazy[rt];
        tree[rt << 1 | 1].realNum=lazy[rt];
        lazy[rt] = 0;
    }
}

void build(int l, int r, int rt)
{
	tree[rt].l = l;
	tree[rt].r = r;
	lazy[rt] = 0;
	if (l == r)
	{
		tree[rt].realNum = a[l];
		if(!Mark[tree[rt].realNum])tree[rt].sum=1;
		else tree[rt].sum=0;

		//printf("Quer ::%d %d  %d\n",tree[rt].l,tree[rt].r,tree[rt].sum);
		return;
	}
	int m = tree[rt].mid();
	build(l, m, (rt << 1));
	build(m + 1, r, (rt << 1 | 1));
	PushUp(rt);
}

void Replace(LL c, int l, int r, int rt)
{
    if (tree[rt].l == l&&tree[rt].r==r)
    {
        lazy[rt] = c;
        if(!Mark[lazy[rt] ])
        {
            tree[rt].sum = (r-l+1);
        }
        else
        {
            tree[rt].sum =0;
        }
        return;
    }
	if (tree[rt].l == tree[rt].r)return;
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	if (r <= m)Replace(c, l, r, rt << 1);
	else if (l > m)Replace(c, l, r, rt << 1 | 1);
	else
	{
		Replace(c, l, m, rt << 1);
		Replace(c, m + 1, r, rt << 1 | 1);
	}
	PushUp(rt);
}

LL Query(int l, int r, int rt)
{
    //printf("Quer ::%d %d  %d\n",tree[rt].l,tree[rt].r,tree[rt].sum);
	if (l == tree[rt].l&&r == tree[rt].r)
	{
		return tree[rt].sum;
	}
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	LL res = 0;
	if (r <= m)res += Query(l, r, rt << 1);
	else if (l > m)res += Query(l, r, rt << 1 | 1);
	else
	{
		res += Query(l, m, rt << 1);
		res += Query(m + 1, r, rt << 1 | 1);
	}
	return res;
}

void Add(LL c, int k, int rt)
{
    if (tree[rt].l == k&&tree[rt].r==k)
	{
	    tree[rt].realNum += c;
		if(!Mark[tree[rt].realNum])tree[rt].sum=1;
		else tree[rt].sum=0;
		//printf("******%d  %lld\n",k,tree[rt].realNum);
		return;
	}
	int m = tree[rt].mid();
	PushDown(rt, tree[rt].r - tree[rt].l + 1);

	if (k <= m)Add(c, k, rt << 1);
	else if (k > m)Add(c, k, rt << 1 | 1);
	PushUp(rt);
}

int main()
{
    int T;
    int tot=Prime();
    Mark[1]=0;
    scanf("%d",&T);
    char op[3];
    while(T--)
    {
        scanf("%d %d",&n,&q);
        for(int i=1;i<=n;i++) scanf("%lld",&a[i]);
        build(1,n,1);
        while(q--)
        {
            scanf("%s",op);
            if(op[0]=='A')
            {
                LL v;
                int l;
                scanf("%lld %d",&v,&l);
                Add(v,l,1);
            }
            else if(op[0]=='Q')
            {
                int ql,qr;scanf("%d %d",&ql,&qr);
                printf("%lld\n",Query(ql,qr,1));
            }
            else
            {
                LL a;int ql,qr;
                scanf("%lld %d %d",&a,&ql,&qr);
                Replace(a,ql,qr,1);
            }
        }
    }
}

 

基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值