NYOJ 160 DNA Sorting

3 篇文章 0 订阅

DNA Sorting

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 
输入
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
输出
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
样例输入
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
样例输出
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
注:排序的话切记不能用sort(),因为它是不稳定排序,需要用stable_sort()稳定排序!!
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct DNA
{
	string dna;
	int count;
} d[101];
int cmp(DNA a,DNA b)
{
 return a.count<b.count;
}
int main()
{
	int n,m,i,j,k;
	char c;
	cin>>n>>m;
	for(i=0;i<m;i++)
	{
	  cin>>d[i].dna;
	  d[i].count = 0;
	  for(j=0;j<n;j++)
		  for(k=j+1;k<n;k++)
		  {
		   if(d[i].dna[j]>d[i].dna[k])
			   d[i].count++;
		  }
	}
	stable_sort(d,d+m,cmp);
	for(i=0;i<m;i++)
		cout<<d[i].dna<<endl;
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值