POJ 3026 Borg Maze (BFS+prim)

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.
Input
On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.
Output
For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.
Sample Input
2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  
Sample Output
8
11

提示:BFS+Prim

大致题意:

在一个y行 x列的迷宫中,有可行走的通路空格’ ‘,不可行走的墙’#’,还有两种英文字母A和S,现在从S出发,要求用最短的路径L连接所有字母,输出这条路径L的总长度。

 

一格的长度为1,而且移动的方法只有上、下、左、右,

所以在无任何墙的情况下(但“墙#”是必须考虑的,这里只是为了说明)

任意两个字母之间的距离就是直接把 横坐标之差 加上 纵坐标之差

注意的是,可行的路为 字母 和 空格

          不可行的路为 # 和 矩阵范围之外

 

根据题意的“分离”规则,重复走过的路不再计算

因此当使用prim算法求L的长度时,根据算法的特征恰好不用考虑这个问题(源点合并很好地解决了这个问题),L就是最少生成树的总权值W

 

由于使用prim算法求在最小生成树,因此无论哪个点做起点都是一样的,(通常选取第一个点),因此起点不是S也没有关系

所以所有的A和S都可以一视同仁,看成一模一样的顶点就可以了

 

最后要注意的就是 字符的输入

cin不读入空字符(包括 空格,换行等)

gets读入空格,但不读入换行符)

 

剩下的问题关键就是处理 任意两字母间的最短距离,由于存在了“墙#” ,这个距离不可能单纯地利用坐标加减去计算,必须额外考虑,推荐用BFS(广搜、宽搜),这是本题的唯一难点,因为prim根本直接套用就可以了

 

求 任意两字母间的最短距离 时不能直接用BFS求,

1、必须先把矩阵中每一个允许通行的格看做一个结点(就是在矩阵内所有非#的格都作为图M的一个顶点),对每一个结点i,分别用BFS求出它到其他所有结点的权值(包括其本身,为0),构造结点图M;

2、然后再加一个判断条件,从图M中抽取以字母为顶点的图,进而构造字母图N

这个判定条件就是当结点图M中的某点j为字母时,把i到j的权值再复制(不是抽离)出来,记录到字母图N的邻接矩阵中

3、剩下的就是对字母图N求最小生成树了


#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<stdio.h>
using namespace std;

const int inf=2501;      //无限大,最大迷宫的总长也就2500

char map[51][51];  //迷宫原图
int node[51][51];   //记录当前格是否为字母,是第几个字母
int col,row;      //当前迷宫的行列数
int num;         //字母顶点数数目
int dist[102][102];      //表示 结点图 的两结点间权值,理论结点数最多为2500个(每一个允许通行的格为一个结点)
                         //但是POJ的数据库允许压缩到101个,哈哈,这样时间和空间复杂度都减少很多
int edge[102][102];      //表示 字母图 的两个字母间的边权,字母数最多为101

class move
{
 public:
    int row,col;
}mov[4]={{0,-1},{0,1},{-1,0},{1,0}}; //分别对应 上 下 左 右

void bfs(int i,int j)
{
    bool vist[51][51];  //标记当前迷宫某一格是否已被访问
    int que_x[2500],que_y[2500];  //坐标队列
    int head=0,tail=0;  //队列指针

    /*Initial*/

    memset(dist,0,sizeof(dist));
    memset(vist,false,sizeof(vist));
    vist[i][j]=true;
    que_x[tail]=i;
    que_y[tail++]=j;  //tail++是指本句运行完了再++

    while(head<tail)
    {
        int x=que_x[head];
        int y=que_y[head++];
        if(node[x][y])
            edge[ node[i][j] ][ node[x][y] ] = dist[x][y];   //抽取字母到字母的边权
        for(int k=0;k<4;k++)  //搜索四个方向
        {
            int mx=x+mov[k].row;
            int my=y+mov[k].col;
            if(mx>=1 && mx<= row && my>=1 && my<=col)
                if(!vist[mx][my] && map[mx][my]!='#')
                {
                    que_x[tail]=mx;
                    que_y[tail++]=my;
                    vist[mx][my]=true;
                    dist[mx][my]=dist[x][y]+1;
                }
        }
    }
    return;
}


int prim(void)
{
    int s=1;
    int m=1;
    bool u[102];//标记是否在S中
    u[s]=true;

    int min_w;  //当前点到S中所有点的最小值
    int prim_w=0;//最小生成树的值
    int point;
    int low_dis[102];//表示当前点到S中所有点的最短距离,距离最小的点最后标记出来

    for(int i=1;i<=num;i++)//初始化。
    {
        low_dis[i]=inf;
        u[i]=false;
    }

    while(true)
    {
        if(m==num)//循环出口,当遍历完所有字母结点的时候
            break;

        min_w=inf;
        for(int i=2;i<=num;i++)
        {
            if(!u[i] && low_dis[i]>edge[s][i])  //更新,经过s好还是不经过s好
                low_dis[i] = edge[s][i];
            if(!u[i] && min_w>low_dis[i])//找到最小边
            {
                min_w=low_dis[i];
                point=i;
            }
        }
        s=point;
        u[s]=true;
        prim_w+=min_w;
        m++; //寻找的字母节点的个数++
    }
    return prim_w; //返回最小生成树的值
}

int main(int i,int j)
{
    int test;
    cin>>test;
    while(test--)
    {
        /*Initial*/

        memset(node,0,sizeof(node));
        num=0;

        /*Input*/

        cin>>col>>row;
        char temp[51];
        gets(temp);  //吃掉cin遗留下来的换行符,我不知道为什么getchar()会AW
        for(i=1;i<=row;i++)
        {
            gets(map[i]);
            for(j=1;j<=col;j++)
                if(map[i][j]=='A'||map[i][j]=='S')
                    node[i][j]=++num;
        }

        /*BFS-> Structure Maps*/

        for(i=1;i<=row;i++)
            for(j=1;j<=col;j++)
                if(node[i][j])
                    bfs(i,j);   //构造结点i,j到其他所有结点的边权(非#的格子就是一个结点)

        /*Prim Algorithm & Output*/

        cout<<prim()<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值