poj 3026 Borg Maze (BFS + Prim)

http://poj.org/problem?id=3026

 

Borg Maze
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
最小生成树问题,但较不同点的是没有给原图,所以要用BFS找各个字母之间的距离,即构成原图
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<queue>
#define INF 0x3f3f3f3f
#define max(a, b)(a > b ? a : b)
#define min(a, b)(a < b ? a : b)
#define N 110

using namespace std;

struct node
{
    int x, y, step;
};

int G[N][N], dist[N], p[N][N];//p记录字母的坐标
bool vis[N], use[N][N];
char maps[N][N];
int m, n, num;
int d[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};

void Init()
{
    int i, j;
    memset(p, 0, sizeof(p));
    memset(vis, false, sizeof(vis));
    for(i = 1 ; i <= num ; i++)
    {
        for(j = 1 ; j <= num ; j++)
        {
            if(i == j)
                G[i][j] = 0;
            else
                G[i][j] = G[j][i] = INF;
        }
    }
}

int prim(int s)//最小生成树,求最小花费
{
    int i, j, index, Min, ans = 0;
    for(i = 1 ; i <= num ; i++)
        dist[i] = G[s][i];
    vis[s] = true;
    for(i = 1 ; i < num ; i++)
    {
        Min = INF;
        for(j = 1 ; j <= num ; j++)
        {
            if(!vis[j] && dist[j] < Min)
            {
                Min = dist[j];
                index = j;
            }
        }
        ans += Min;
        vis[index] = true;
        for(j = 1 ; j <= num ; j++)
        {
            if(!vis[j] && dist[j] > G[index][j])
                dist[j] = G[index][j];
        }
    }
    return ans;
}

void BFS(int x, int y)//广搜构建原图
{
    queue<node>Q;
    int i, a, b;
    node now, next;
    memset(use, false, sizeof(use));
    now.x = x;
    now.y = y;
    now.step = 0;
    use[x][y] = true;
    Q.push(now);
    while(!Q.empty())
    {
        now = Q.front();
        Q.pop();
        if(p[now.x][now.y] > 0)//该点为字母
            G[p[x][y]][p[now.x][now.y]] = now.step;
        for(i = 0 ; i < 4 ; i++)
        {
            a = next.x = now.x + d[i][0];
            b = next.y = now.y + d[i][1];

            if(a >= 0 && a < m && b >= 0 && b < n && !use[a][b] && maps[a][b] != '#')
            {
                next.step = now.step + 1;
                use[a][b] = true;
                Q.push(next);

            }
        }
    }
}

int main()
{
    int i, j, t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d ", &n, &m);
        Init();
        num = 0;
        for(i = 0 ; i < m ; i++)
        {
            for(j = 0 ; j < n ; j++)
            {
                scanf("%c", &maps[i][j]);
            }
            getchar();
        }
        for(i = 0 ; i < m ; i++)
        {
            for(j = 0 ; j < n ; j++)
            {
                if(maps[i][j] == 'A' || maps[i][j] == 'S')
                    p[i][j] = ++num;//统计字母的个数,即要进入树的点的个数
            }
        }
        for(i = 0 ; i < m ; i++)
        {
            for(j = 0 ; j < n ; j++)
                if(p[i][j] > 0)
                    BFS(i, j);
        }
        printf("%d\n", prim(1));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/qq2424260747/p/4684913.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值