CDZSC_2015寒假新人(4)——搜索 A

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
 
思路:用bfs来找最优解,注意边界问题(我错了好多次)。。。。c+1和c*2他不可能比100000大太多,不然要减很多次就不是最优解,所以c+2和c*2我都让他小于100100.
 
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define Maxn 200100
using namespace std;
int vis[Maxn],n,k,sum;
int bfs(int a,int b)
{
    int c;
    memset(vis,0,sizeof(vis));
    queue<int> q;
    q.push(a);
    while(!q.empty())
    {
        c=q.front();
        q.pop();
        if(c==b)
        {
            break;
        }
        if(vis[c-1]==0&&c-1>=0)
        {
            vis[c-1]=vis[c]+1;
            q.push(c-1);
        }
        if(vis[c+1]==0&&c+1<=Maxn/2)
        {
            vis[c+1]=vis[c]+1;
            q.push(c+1);
        }
        if(vis[c*2]==0&&2*c<=Maxn/2)
        {
            vis[c*2]=vis[c]+1;
            q.push(c*2);
        }
    }
    return vis[b];
}
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n>=k)
        {
            printf("%d\n",n-k);
        }
        else
        {
            printf("%d\n",bfs(n,k));
        }
    }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/Wing0624/p/4251421.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值