【差分约束】poj 1201 Intervals

Intervals

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36452 Accepted: 13881

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

[li,ri]之间有c个,则s[ri]-s[li]>=c (s表示前缀和)

然后由于每个点最多放一个

所以还有一个隐含的条件:0<=s[i+1]-s[i]<=1

加完这三种边之后,spfa跑最长路即可

 

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue> 
using namespace std;
#define PII pair<int,int>
const int maxn=5e4+5;
const int inf=0x3f3f3f3f;
int n,m,minn,maxx,head[maxn],vis[maxn],dis[maxn],cnt;
struct edge
{
	int to,nxt,v;
}e[maxn<<2];
void add(int x,int y,int z)
{
	e[++cnt].to=y;
	e[cnt].nxt=head[x];
	e[cnt].v=z;
	head[x]=cnt;
}
void spfa()
{
	queue <int> q;
	dis[minn]=0; q.push(minn);
	while(!q.empty())
	{
		int u=q.front();
		q.pop(); vis[u]=0;
		for(int i=head[u];i;i=e[i].nxt)
		{
			int to=e[i].to;
			if(dis[to]<dis[u]+e[i].v)
			{
				dis[to]=dis[u]+e[i].v;
				if(!vis[to])
					vis[to]=1,q.push(to);
			}
		}
	}
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	while(scanf("%d",&n)==1)
	{
		memset(head,0,sizeof(head));
		cnt=0; memset(vis,0,sizeof(vis));
		int x,y,z;
		minn=inf,maxx=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			add(x,y+1,z);
			minn=min(minn,x);
			maxx=max(maxx,y+1);
		}
		for(int i=minn;i<maxx;i++) add(i+1,i,-1),add(i,i+1,0);
		memset(dis,-0x3f,sizeof(dis));
		spfa();
		printf("%d\n",dis[maxx]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值