【Trie】hdu 1247 Hat’s Words

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22924    Accepted Submission(s): 8049


 

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

 

Sample Input
 
a ahat hat hatword hziee word
 

 

Sample Output
 
ahat hatword
 
 
建了Trie树之后,直接枚举查找即可
 
 
代码
#include<bits/stdc++.h>
using namespace std;
char c[50005][30];
int ch[50005][30],k,tot,cnt[50005];
void insert(char *s)
{
	int now=0,len=strlen(s);
	for(int i=0;i<len;i++)
	{
		int dig=s[i]-'a';
		if(!ch[now][dig]) ch[now][dig]=++tot;
		now=ch[now][dig];
	}
	cnt[now]=1;
}
int check(int k,int pos)
{
	int now=0,len=strlen(c[k]);
	for(int i=pos;i<len;i++)
	{
		int dig=c[k][i]-'a';
		if(!ch[now][dig]) return 0;
		now=ch[now][dig]; 
	}
	if(cnt[now]>0) return 1;
	else return 0;
}
int find(int k)
{
	int now=0,len=strlen(c[k]);
	for(int i=0;i<len;i++)
	{
		int dig=c[k][i]-'a';
		if(cnt[now]>0 && check(k,i)) return 1;
		now=ch[now][dig]; 
	}
	return 0;
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	while(scanf("%s",c[++k])!=EOF)
	{
		insert(c[k]);
	}
	for(int i=1;i<=k;i++)
		if(find(i))
		{
			for(int j=0;j<strlen(c[i]);j++)
				printf("%c",c[i][j]);
			printf("\n");
		}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值