POJ-2531 Network Saboteur 解题报告

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90


       题目链接:http://poj.org/problem?id=2531

       解法类型:DFS | 其他

       解题思路:我是暴力解决的,直接用位运算或数组模拟A和B的所有情况,然后分别计算出最大值,最后比较最大值就可以了。注意要避免重复运算的两种情况。时间效率不高啊,563MS。。。。

       算法实现:

//STATUS:C++_AC_563MS_168K
#include<stdio.h>
const int MAXN=30;
int DFS(int cur);
int sum(int c);
int map[MAXN][MAXN],C,max,N;
int main()
{
//	freopen("in.txt","r",stdin);
	int i,j;
	while(scanf("%d",&N)!=EOF)
	{
		C=0;
		max=0x80000000;  //初始化最大值

		for(i=0;i<N;i++){
			for(j=0;j<N;j++)
				scanf("%d",&map[i][j]);
		}

		DFS(0);

		printf("%d\n",max);
	}
	return 0;
}

int DFS(int cur)
{
	if(cur>N)return 1;  //search complete
	if(C&(1<<(cur-1))){  //避免重复计算两种相同的情况
     	int t;
    	t=sum(C);
     	max=t>max?t:max;
	}

	C|=(1<<cur);  //位运算模拟分为两部分
	DFS(cur+1);
	C&=~(1<<cur);  //回溯
	DFS(cur+1);  //搜索0

	return 0; //error
}

int sum(int c)
{
	int i,j,ma=0,mb=0,tot=0,A[MAXN],B[MAXN];
	for(i=0;i<N;i++)
		c&(1<<i)?A[ma++]=i:B[mb++]=i;  //把nodes分为两部分
	for(i=0;i<ma;i++){   //计算可能最大的traffic
		for(j=0;j<mb;j++)
			tot+=map[A[i]][B[j]];
	}
	return tot;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值