USACO Section 2.3 Money Systems (整数划分完全背包思想)

Money Systems

The cows have not only created their own government but they have chosen to create their own money system. In their own rebellious way, they are curious about values of coinage. Traditionally, coins come in values like 1, 5, 10, 20 or 25, 50, and 100 units, sometimes with a 2 unit coin thrown in for good measure.

The cows want to know how many different ways it is possible to dispense a certain amount of money using various coin systems. For instance, using a system of {1, 2, 5, 10, ...} it is possible to create 18 units several different ways, including: 18x1, 9x2, 8x2+2x1, 3x5+2+1, and many others.

Write a program to compute how many ways to construct a given amount of money using supplied coinage. It is guaranteed that the total will fit into both a signed long long (C/C++) and Int64 (Free Pascal).

PROGRAM NAME: money

INPUT FORMAT

The number of coins in the system is V (1 <= V <= 25).

The amount money to construct is N (1 <= N <= 10,000).

Line 1:Two integers, V and N
Lines 2..:V integers that represent the available coins (no particular number of integers per line)

SAMPLE INPUT (file money.in)

3 10
1 2 5

OUTPUT FORMAT

A single line containing the total number of ways to construct N money units using V coins.

SAMPLE OUTPUT (file money.out)

10

题意:给你 n 种不同面值货币和面值为 v 的货币,用 n 种不同的面值的货币组成 v 有多少种组合。
分析:完全背包
View Code
/*
  ID: dizzy_l1
  LANG: C++
  TASK: money
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#define MAXN 30
#define MAXV 10010

using namespace std;

long long d[MAXV];
int a[MAXN];

FILE *fin  = fopen ("money.in", "r");
FILE *fout = fopen ("money.out", "w");

int main()
{
    int n,v,i,j;
    while(fscanf(fin,"%d %d",&n,&v)==2)
    {
        memset(d,0,sizeof(d));
        for(i=0;i<n;i++)
            fscanf(fin,"%d",&a[i]);
        d[0]=1;
        for(i=0;i<n;i++)
        {
            for(j=a[i];j<=v;j++)
            {
                d[j]+=d[j-a[i]];
            }
        }
        fprintf(fout,"%lld\n",d[v]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/zhourongqing/archive/2012/09/04/2670538.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值