POJ 1742 Coins

POJ 1742 Coins

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题目大意:
给定n种硬币,并给出这些种硬币的价值和数量,求能凑出几种不同种类的面值。
题目分析:
多重背包问题的最简单变形。
题目解法:
多重背包模板+二进制优化。
这里讲一下二进制优化及其代码实现。
其实所有的背包问题,除了01背包之外,其基本思路都是转化成01背包问题求解。完全背包如此,多重背包亦然。
多重背包较之完全背包,只是加了个数量限制。
那么我们就可以把多重背包的每种物品拆分成n个物品(题目中给出n)
所以就可以求解。
但是这个东西很容易爆炸。
即使不爆炸,也很占空间。
所以我们考虑了二进制优化。
什么是二进制优化呢?
这是一种数学常识,假如我们把一个数拆成2的连续k次幂的和,不够的直接落下来。
比如13 拆成 1,2,4,6
就可以通过排列组合加出13以内的任何自然数。
这就是二进制优化的思想,既然是01背包,只需要把每个物品决策一下:选还是不选,正好适合这个思想。
所以本题可解。
至于POJ的多组数据,特殊处理就可以。

代码:
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,cnt;
int w[101];
int dp[1000001];
int c[100001];
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF && n &&m)
    {
        cnt=0;
        for(int i=1;i<=m;i++)
            dp[i]=0;
        for(int i=0;i<n;i++)
            scanf("%d",&w[i]);
        for(int i=0;i<n;i++)
        {
            int num;
            scanf("%d",&num);
            int k=1;
            while(k<num)
            {
                c[cnt++]=k*w[i];
                num-=k;
                k*=2;
            }
            c[cnt++]=num*w[i];
        }
        dp[0]=1;
        for(int i=0;i<cnt;i++)
            for(int j=m;j>=c[i];j--)
                if(dp[j]==0)
                    dp[j]=dp[j-c[i]];
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i])
                ans++;
        printf("%d\n",ans);
    }
    return 0;
}

代码说明:

w数组存价值,c数组存数量,dp数组表示能否凑出来i价值。

#include <cstdio>
#include <cstring>
using namespace std;
int n,m,cnt;
int w[ 101];
int dp[ 1000001];
int c[ 100001];
int main()
{
while( scanf( "%d%d",&n,&m)!=EOF && n &&m)
{
cnt= 0;
for( int i= 1;i<=m;i++)
dp[i]= 0;
for( int i= 0;i<n;i++)
scanf( "%d",& w[i]);
for( int i= 0;i<n;i++)
{
int num;
scanf( "%d",&num);
int k= 1;
while(k<num)
{
c[cnt++]=k* w[i];
num-=k;
k*= 2;
}
c[cnt++]=num* w[i];
}
dp[ 0]= 1;
for( int i= 0;i<cnt;i++)
for( int j=m;j>= c[i];j--)
if( dp[j]== 0)
dp[j]= dp[j- c[i]];
int ans= 0;
for( int i= 1;i<=m;i++)
if( dp[i])
ans++;
printf( "%d \n ",ans);
}
return 0;
}

转载于:https://www.cnblogs.com/fusiwei/p/11248399.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值