poj 1742 多重背包算法优化问题

Coins
Time Limit: 3000MS  Memory Limit: 30000K
Total Submissions: 26971  Accepted: 9152

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0

Sample Output

8 4

Source

这道题目的思路就是多重背包解法。
首先是O(m*Σlog coinNum[i]) 方法,刚开始超时了,看了下别人已经AC过的代码,
然后通过把int类型的数组改成bool类型的数组成功AC 耗时2219MS 
#include <cstdio>
//男人八题   多重背包
#define N 100
#define M 100000
int coins[N + 1];
int coinNum[N + 1];
bool f[M + 1];
int n, m;
int Min(int a, int b)
{
return a < b ? a : b;
}
void _01pack(int cost)
{
for(int i = m; i >= cost; i--)
f[i] |= f[i - cost];
}
void multipack(int cost, int num)
{
if(cost * num >= m)
for(int i = cost; i <= m; i++)
f[i] |= f[i - cost];
else
{
int k = 1;
while(k < num)
{
_01pack(k * cost);
num -= k;
k <<= 1;
}
_01pack(num * cost);
}
}
int main()
{
int sum = 0, num, value;
while(scanf("%d %d", &n, &m), n || m)
{
value = 1000000;
for(int i = 0; i < n; i++)
{
scanf("%d", &coins[i]);
value = Min(value, coins[i]);
}
for(int i = 0; i < n; i++)
scanf("%d", &coinNum[i]);
sum = 0;
for(int i = 0; i < n; i++)
sum += coins[i] * coinNum[i];
m = Min(m ,sum);
for(int i = f[0] = 1; i <= m; i++)
f[i] = 0;
for(int i = 0; i < n; i++)
{
if(coins[i] > m)
continue;
multipack(coins[i], coinNum[i]);
}
num = 0;
for(int i = value; i <= m; i++)
num += f[i];
printf("%d\n",num);
}

return 0;
}


下面是楼教主的O(m*n)方法,耗时1500MS,新添的sum数组巧妙地降低了算法的时间复杂度。
#include <cstdio>
#define M 100000
#define N 100
bool f[M + 1];
int sum[M + 1];
int value[N + 1], num[N + 1];
int n, m;
// O(Vn)
int main()
{
int ans;
while(scanf("%d %d", &n, &m), n || m)
{
for(int i = 0; i < n; i++ )
scanf("%d", &value[i]);
for(int i = 0; i < n; i++)
scanf("%d", &num[i]);
for(int i = f[0] = 1; i <= m ;i++)
f[i] = 0;
ans = 0;
for(int i = 0 ; i < n; i++)
{
for(int j = 0; j <= m ;j++)
sum[j] = 0;
for(int j = value[i]; j <= m; j++)
{
if(!f[j] && f[j - value[i]] && sum[j - value[i]] < num[i])
{
f[j] = 1;
sum[j] = sum[j - value[i]] + 1;
ans++;
}
}
}
printf("%d\n", ans);
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值