【题解】poj1742 Coins 多重背包+贪心

该博客介绍了一个关于Silverland银币的多重背包问题,Tony试图用不同面值的硬币购买手表,需要支付确切的价格。博客提供了一种贪心算法来计算在不超过m的金额下,有多少种价格可以用这些硬币支付,并给出了输入输出示例及问题总结。
摘要由CSDN通过智能技术生成

题目链接

Description

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4


若前 i i i 种硬币能拼成面值 j j j,只有两类可能情况:
1. 1. 1. i − 1 i-1 i1 种硬币就能拼成面值 j j j,即在第 i i i 阶段开始前,变量 F [ j ] F[j] F[j] 已经成为 t r u e true true
2. 2. 2. 使用了第 i i i 种硬币,即在第 i i i 阶段的递推中,发现 F [ j − a [ i ] ] F[j-a[i]] F[ja[i]] t r u e true true
u s e d [ j ] used[j] used[j] 表示 F [ j ] F[j] F[j] 在阶段 i i i 时为 t r u e true true 至少需要用多少枚第 i i i 种硬币。

#include<cstdio>
#include<cstring>
const int N=110,M=1e5+10;
int n,m,a[N],used[M],c[N],cnt;
bool f[M];
int main()
{
	//freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
    	memset(f,false,sizeof(f));
    	for(int i=1;i<=n;i++)
    	    scanf("%d",&a[i]);
    	for(int i=1;i<=n;i++)
    	    scanf("%d",&c[i]);
    	f[0]=true;
    	for(int i=1;i<=n;i++)
    	{
    		memset(used,0,sizeof(used));
    		for(int j=a[i];j<=m;j++)
    		    if(!f[j]&&f[j-a[i]]&&used[j-a[i]]<c[i])
    		        f[j]=true,used[j]=used[j-a[i]]+1;
		}
		cnt=0;
		for(int i=1;i<=m;i++)
		    cnt+=f[i];
		printf("%d\n",cnt);
	}
	return 0;
}

总结

利用贪心策略优化时间复杂度。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值