aoj.339.Large or small

Large or small

Description
Only Input and Output

Input
Several cases.
A letter indicating the operation('L' means to output the lager one while 'S' the smaller).
Followed by two integers. It's guaranteed that all numbers are smaller than 10^5.

Output
According to the operation to output the lager or smaller integer on a seperate line.
If the letter is not 'L' or 'S' just print "Input error!".

Sample Input
L 3 4
S 3 4
Sample Output
4
3



法一:清理缓存法

   
   
#include"stdio.h"
int main()
{
char ch;
long x,y;
while(scanf("%c",&ch)!=EOF)
{
scanf("%ld %ld",&x,&y);
if(ch=='L')
printf("%ld\n",x>y?x:y);
else if(ch=='S')
printf("%ld\n",y>x?x:y);
else
printf("Input error!\n")
fflush(stdin); /*清理缓存,清除上次执行命令的换行*//*aoj无法通过??*/
}
return 0;
法二:当输入换行时执行下次循环,去除关于换行的代入执行
#include"stdio.h" 
int main()
{
    char ch;
    long x,y;
    while(scanf("%c",&ch)!=EOF)
    {
        if(ch=='\n')             /*判断读入的是否为换行符*//*换行符来自上次最后键入的命令*/
            continue;  /*是则结束本次循环*/
        scanf("%ld %ld",&x,&y);
        if(ch=='S')
            printf("%ld\n",x<y?x:y);
        else if(ch=='L')
            printf("%ld\n",x>y?x:y);
        else
            printf("Input error!\n");
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值