AOJ.864 函数

Time Limit: 1000 ms   Memory Limit: 50 MB
Total Submission: 10   Submission Accepted: 5
Judge By Case
Description
计算ackerman函数值:

Input
第一行为两个数,即M和N,其中0<=M<=3,0<=N<=11。

Output
输出ack(m,n)的值。

Sample Input
OriginalTransformed
0 1
0[SP]1[EOF] 

Sample Output
OriginalTransformed
2
2[EOL] 

[EOF] 

题目不难,不知道直接递归会不会爆时间,记忆化搜索一定要注意一下要开的数组是多大,多么痛的领悟

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
//#define DEBUG
#define INF 100000000
const int maxn =1050;
using namespace std;
int a[4][5000];
int ack(int m, int n);
int main() {
#ifdef DEBUG
	freopen("Text.txt", "r", stdin);
#endif // DEBUG
	int m, n;
	while (scanf("%d %d", &m, &n)!=EOF) {
		//printf("m = %d, n = %d\n", m, n);
		memset(a, -1, sizeof(a));
		ack(m, n);
		printf("%d\n", ack(m, n));
	}
	return 0;
}
int ack(int m, int n) {
	printf("m = %d, n = %d\n", m, n);
	if (a[m][n] != -1)return a[m][n];
	else if (m == 0)
		return a[m][n] = n + 1;
	else if (n == 0)
		return a[m][n] = ack(m - 1, 1);
	else if (m > 0 && n > 0)
		return a[m][n] = ack((m - 1), ack(m, n - 1));
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值