Small Multiple

Find the smallest possible sum of the digits in the decimal notation of a positive multiple of K.
Constraints
2≤K≤105
K is an integer.

 

 

输入

Input is given from Standard Input in the following format:
K

 

输出

Print the smallest possible sum of the digits in the decimal notation of a positive multiple of K.

 

样例输入

6

 

样例输出

3

 

提示

12=6×2 yields the smallest sum.

题意:给你一个数n,找到n的倍数各个位上加起来的最小值。

思路:

因为是n的倍数,对与数x,只需要取x属于[1,k]之间,在数后加0~9来构成一个新数y,保证y%k==0,即是各个

位数取和的最小的k的倍数,为了保证不必要的位数加进来,导致结果不是最优,所以采用取模处理,所

以只需要看对k取模的余数即可,

在每一个数之间建立边权,每个节点代表该数对k取模的结果,两节点之间的边权代表各个位数和的差值

x  -----x+1    各个位数的差值之和相差为1,所以边权为1;

x------x*10  各个位数的和加个0之后,其值不变,所以边权为0;

然后进行最短路,从取模为1,的节点,到取模为0 的节点的最短路的值,及时所求答案

/*Du Jinzhi*/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <math.h>
#include <cstring>
#include <string>
#include <queue>
#include <deque>
#include <stack>
#include <stdlib.h>
#include <list>
#include <map>
#include <utility>
#include <set>
#include <bitset>
#include <vector>
#define pi acos(-1.0)
#define inf 0x3f3f3f3f
#define ll long long
#define linf 0x3f3f3f3f3f3f3f3fLL
using namespace std;
const int N = 1e5+5;
const ll mod = 1e9+7;
const ll INF = 1e18;
int head[N];
int ne;
struct edge{
    int to,nt,w;
}e[500004];
queue<int>q;
int dis[100004];
void spfa()
{
    memset(dis,127/3,sizeof(dis));
    dis[1]=0;
    while(!q.empty()){
        int x=q.front();q.pop();
        for(int i=head[x];i;i=e[i].nt){
            if( dis[e[i].to]>dis[x]+e[i].w){
                dis[e[i].to]=dis[x]+e[i].w;
                q.push(e[i].to);
            }
        }
    }
}
void add(int u,int v,int w){
     e[++ne].to = v;e[ne].nt = head[u];
     e[ne].w=w;
     head[u]=ne;
}

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        add(i,(i+1)%n,1);
        add(i,(i*10)%n,0);
    }
    q.push(1);
    spfa();
    printf("%d\n",dis[0]+1);

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值