poj 2407 Relatives

RelativesTime Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10269 Accepted: 4950


Description
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output
For each test case there should be single line of output answering the question posed above.

Sample Input
7
12
0

Sample Output
6
4

Source
Waterloo local 2002.07.01

//184K    0MS    C++    416B    
//欧拉函数..竟然没反应过来
//   H(n)=n*(1-1/a1)*(1-1/a2)*..*(1-1/an)
//   其中,ai为n的质因数 
#include<stdio.h>
#include<math.h> 
int euler(int n)
{
    int ret=n;
    for(int i=2;i<(int)sqrt(n*1.0)+1;i++){
        if(n%i==0){
            n/=i;
            ret=ret/i*(i-1);
            while(n%i==0) n/=i;
        }
    }
    if(n>1) ret=ret/n*(n-1);
    return ret;
}
int main(void)
{
    int n;
    while(scanf("%d",&n),n)
    {
        printf("%d\n",euler(n));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/GO-NO-1/articles/3331722.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值