博弈论入门题 kiki's game

Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

 

Sample Input
5 3 5 4 6 6 0 0
 

 

Sample Output
What a pity! Wonderful! Wonderful!
 

 

Author
月野兔
 

 

Source
 

 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   1846  1847  1848  1849  1517 
 
 
 
显然(1,1)是必败态,因为没有操作可以选择
那么由必胜态的定义(一步之内能走到必败态的状态叫必胜态)(1,2),(2,2),(2,1)都是必胜态
依次类推可以打一个表出来(必败态:下一步无论怎样转移都会转移到必胜态)
找规律
n,m都是奇数的时候会输!
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<functional>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;

#define N 100
#define MAXN 20000 + 9
#define INF 1000000009
#define eps 0.00000001
#define sf(a) scanf("%d",&a)

int n;
int a[N];
int main()
{
    while (sf(n), n)
    {
        int sum = 0;
        for (int i = 0; i < n; i++)
            sf(a[i]), sum ^= a[i];
        if (sum == 0)
            cout << 0 << endl;
        else
        {
            int ans = 0;
            for (int i = 0; i < n; i++)
            {
                if ((sum^a[i]) < a[i])
                    ans++;
            }
            cout << ans << endl;
        }
    }
}

 

转载于:https://www.cnblogs.com/joeylee97/p/7497420.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值