博弈——kiki's game

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game? 
Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0. 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!". 
Sample Input
5 3
5 4
6 6
0 0
Sample Output
What a pity!
Wonderful!
Wonderful!


题意:k和z下棋,规则如下:

1.棋盘大小是n*m,每次都是k先走,棋盘上只有一颗子且最开始在右上角

2.每个人每次只能把棋子移动到左或下或左下这三个位置

3.谁不能移动谁输

求k是否胜利,是就输出Wonderful!否就输出What a pity!


思路:

由题意可以知道n=m=1时k必败,那么必败态可以转移到右或上或右上,这几个都为必胜态。如果一个格子无论怎么移动都不能到必败态,那么这个格子为必败态

所以可以手动画图,发现当n和m都是奇数时k必输,否则k赢。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n, m;
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        if(n==0&&m==0)
            break;
        if((n&1)&&(m&1))
            printf("What a pity!\n");
        else
            printf("Wonderful!\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值