POJ 3370 Halloween treats(抽屉原理)

Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6631 Accepted: 2448 Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source




题意:给出c和n,接下来n个数,求随意的几个数的和为c的倍数,输出随意一组答案(注意是随意的)


抽屉原理: 放10个苹果到九个抽屉,最少有一个抽屉有大于1的苹果


这个题为什么说是抽屉原理呢?  你计算前n个数(一共同拥有n个和)的和mod  c ,由于n大于c,所以你推測会有多少个余数。

最多有 n个。即 0~n-1,而0是满足条件的,换而言之。这n个余数中要么有0,要么最少有两个同样的余数,

如今看两个余数同样的情况,比如   如果sum[1]%c==sum[n]%c  那么a[2]+a[3]+..+a[n]就是 c  的倍数。就说这么多了。

看代码吧:






#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100005

int a[N];
int vis[N];
int c,n;

int main()
{
    int i;
    while(~scanf("%d%d",&c,&n))
    {
        memset(vis,-1,sizeof(vis));

        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }

        int temp=0,j;


        for(i=1;i<=n;i++)
        {
            temp+=a[i];
            temp%=c;

            if(temp==0)
            {
                for(j=1;j<=i;j++)
                    if(j==1)
                       printf("%d",j);
                    else
                       printf(" %d",j);

               printf("\n");
                break;
            }

            if(vis[temp]!=-1)
            {

                for(j=vis[temp]+1;j<=i;j++)
                  if(i==j)
                      printf("%d",j);
                   else
                      printf("%d ",j);

                      printf("\n");

              break;
            }

            vis[temp]=i;
        }

    }
    return 0;
}





转载于:https://www.cnblogs.com/mfmdaoyou/p/7152383.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值