HDOJ 5088 Revenge of Nim II 位运算


位运算。。

。。

Revenge of Nim II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 229    Accepted Submission(s): 79


Problem Description
Nim is a mathematical game of strategy in which two players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.
---Wikipedia

Today, Nim takes revenge on you, again. As you know, the rule of Nim game is rather unfair, only the nim-sum (⊕) of the sizes of the heaps is zero will the first player lose. To ensure the fairness of the game, the second player has a chance to move some (can be zero) heaps before the game starts, but he has to move one heap entirely, i.e. not partially. Of course, he can’t move all heaps out, at least one heap should be left for playing. Will the second player have the chance to win this time?

 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the number of heaps. Then N integer Ai follows, indicating the number of each heap.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= N <= 1 000
3. 1 <= Ai <= 1 000 000 000 000
 

Output
For each test case, output “Yes” if the second player can win by moving some (can be zero) heaps out, otherwise “No”.
 

Sample Input
 
   
3 1 2 3 2 2 2 5 1 2 3 4 5
 

Sample Output
 
   
No Yes Yes
Hint
For the third test case, the second player can move heaps with 4 and 5 objects out, so the nim-sum of the sizes of the left heaps is 1⊕2⊕3 = 0.
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

int n;
LL c[60];
LL a[1100];

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            cin>>a[i];
        bool flag=false;
        for(int i=1;i<=n;i++)
        {
            for(int j=60;j>=0;j--)
            {
                if(c[j]==0&&(a[i]&(1LL<<j)))
                {
                    c[j]=a[i];
                    break;
                }
                else if(a[i]&(1LL<<j))
                {
                    a[i]^=c[j];
                    if(a[i]==0) flag=true;
                }
            }
        }
        if(flag==true) puts("Yes");
        else puts("No");
    }
    return 0;
}



转载于:https://www.cnblogs.com/lcchuguo/p/5159995.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值