hdu 1316 How Many Fibs?

题目(http://acm.hdu.edu.cn/showproblem.php?pid=1316)

Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 


Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.


Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 


Sample Input
10 100
1234567890 9876543210
0 0


Sample Output
5
4

求a到b之间有多少个斐波那契数,数很大只能用高精度

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

string add(string s1,string s2)
{
     if(s1.length()<s2.length())
     {
          string temp=s1;
          s1=s2;
          s2=temp;
     }
     for(int i=s1.length()-1,j=s2.length ()-1;i>=0;i--,j--)
     {
          s1[i]=char(s1[i]+(j>=0?s2[j]-'0':0));
          if(s1[i]-'0'>=10)
          {
              s1[i]=char((s1[i]-'0')%10+'0');
              if(i)
                   s1[i-1]++;
              else
                   s1='1'+s1;
          }
     }
     return s1;
}

string f[1005],a,b;

int main()
{
    int i;
    f[1]='1';
    f[2]='2';
    for(i=3;i<1005;i++)
    f[i]=add(f[i-2],f[i-1]);//打表
    while(cin>>a>>b)
    {
        if(a=="0"&&b=="0")
        break;
        int left,right,cnt = 0,len_a,len_b,len;
        len_a=a.length();
        len_b=b.length();
        for(i=1;i<1005;i++)
        {
            len=f[i].length();
            if(len<len_a)
            continue;
            else if(len==len_a&&f[i]>=a)
            {
                left=i;
                break;
            }
            else if(len>len_a)
            {
                left=i;
                break;
            }
        }
        for(i=1004;i>=1;i--)
        {
            len=f[i].length();
            if(len>len_b)
            continue;
            else if(len==len_b&&f[i]<=b)
            {
                right=i;
                break;
            }
            else if(len<len_b)
            {
                right=i;
                break;
            }
        }
        printf("%d\n",right-left+1);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值