hdu 1316 How Many Fibs?

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3941    Accepted Submission(s): 1564


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
 
<span style="font-size:18px;">import java.math.BigInteger;
import java.util.Scanner;

public class pp {
	
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		BigInteger n,m;
		    
			BigInteger a[]=new BigInteger[10000];
			a[1]=new BigInteger("1");
			a[2]=new BigInteger("2");
			for(int i=3;i<=1005;i++)
				a[i]=a[i-1].add(a[i-2]);
		while(cin.hasNext())
		{  
			n=cin.nextBigInteger();
			m=cin.nextBigInteger();
			int sum=0;
		    if(n.compareTo(BigInteger.ZERO)==0&&m.compareTo(BigInteger.ZERO)==0)   //n==0 || m==0
		        return;
		    if(n.compareTo(m)>0)     // 相当于n>m
		    {
			  BigInteger t= n;
			  n = m;
			  m = t;
		    }

			for(int i=1;i<=1005;i++)
			{
			  if(a[i].compareTo(n)>=0 &&a[i].compareTo(m)<=0)  // a[i]>=0 && a[i]<=m
				sum++;
			}
			System.out.println(sum);
		}
		
	}
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值