hdu1426搜索

8 篇文章 0 订阅

http://poj.org/problem?id=1426
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111

题意,找出任意一个由0和1组成的数能整除n。
一开始bfs超时

#include <iostream>
#include <queue>
using namespace std;
int n;
long long num;
long long bfs()
{
    queue<long long>q;
    q.push(1);
    while(!q.empty())
    {
        num=q.front();
        q.pop();
        if(num%n==0)
        break;
        q.push(10*num);
        q.push(10*num+1);
    }
    return num;
}
int main()
{while(cin>>n&&n)
 {
     bfs();
     cout<<num<<endl;
 }
    return 0;
}

dfsAC

#include <iostream>
#include <cstdio>
using namespace std;

bool found;
int n;

void dfs(unsigned long long num,int deep)
{
    if(found)
        return;
    if(num%n==0)
    {
        found=true;
        cout<<num<<endl;
        return;
    }
    if(deep>=19)//搜索第19就返回.20位装不下了
        return;
    dfs(num*10,deep+1);
    dfs(num*10+1,deep+1);
}

int main()
{
    while(cin>>n&&n)
    {
        found=false;
        dfs(1,0);
    }
    return 0;
}

生找

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;


int n;
long long q[maxn];

long long work()
{
    int front = 0;
    int rear = 0;

    q[rear++] = 1;
    while (1)
    {
        long long temp = q[front++];
        if ((temp * 10) % n == 0)
            return temp * 10;
        if ((temp * 10 + 1) % n == 0)
            return temp * 10 + 1;
        q[rear++] = temp * 10;
        q[rear++] = temp * 10 + 1;
    }
    return -1;
}

int main()
{
//    for (n = 1; n <= 200; n++)
//        printf("%lld\n", work());
    while (scanf("%d", &n), n)
        printf("%lld\n", work());
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值