hdu4585map应用

http://acm.split.hdu.edu.cn/showproblem.php?pid=4585

Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.


Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.


Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.


Sample Input
3
2 1
3 3
4 2
0


Sample Output
2 1
3 2
4 2


Source
2013ACM-ICPC杭州赛区全国邀请赛

平衡树解决。
利用map的特性,插入的元素是有序的,红黑树处理过,使得查询为o(nlogn)

#include <iostream>
#include <map>
#include <cstdio>

using namespace std;

map<int,int>M;
map<int,int>::iterator it;
map<int,int>::iterator it2,it3;
int main()
{
    int n,id,p;
    while(scanf("%d",&n)&&n)
    {  ///map<int,int>M;如果每次定义的话就不用清空
        M[1000000000]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&id,&p);
            it=M.lower_bound(p);
            if(it==M.begin())//他是最弱的
            printf("%d %d\n",id,it->second);
            else
            {
                it2=it;
                it3=--it;
                if((it2->first)-p>=p-(it3->first))//判断谁的武力值更接近他
                printf("%d %d\n",id,it3->second);
                else
                printf("%d %d\n",id,it2->second);
            }
            M[p]=id;
        }
        M.clear();//不要忘记清空
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值