hdu5475 线段树单点更新

http://acm.hdu.edu.cn/showproblem.php?pid=5475

Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.


Input
The first line is an integer T(1≤T≤10), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤109)
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. (0<y≤109)
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.


Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.


Sample Input
1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7


Sample Output
Case #1:
2
1
2
20
10
1
6
42
504
84

题意,原来x为1,有1,2两种操作,
1:x乘以一个数
2:x除以第y次操作乘的数
思路 线段树存下所有的操作要进行除操作的时候,把当时乘的数变为1就行了

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

typedef long long ll;
const int maxn=1e5+10;

ll a[maxn<<2];
ll mod;
int q;
void build(int l,int r,int rt)
{
    if(l==r)
    {
        a[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    a[rt]=1;
}
void update(int l,int r,int pos,ll mul,int rt)
{
    if(l==r)
    {
        a[rt]=mul;
        return;
    }
    int m=(l+r)>>1;
    if(pos<=m) update(l,m,pos,mul,rt<<1);
    else update(m+1,r,pos,mul,rt<<1|1);
    a[rt]=(a[rt<<1]*a[rt<<1|1])%mod;
}
int main()
{
    int t;
    int x,y;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        printf("Case #%d:\n",cas);
        scanf("%d%lld",&q,&mod);
        build(1,q,1);
        for(int i=1;i<=q;i++)
        {
            scanf("%d%d",&x,&y);
            if(x==1)
            {
                update(1,q,i,y,1);
                printf("%lld\n",a[1]);
            }
            else
            {
                update(1,q,y,1,1);
                printf("%lld\n",a[1]);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值