HDU 5621 KK's Point

78 篇文章 0 订阅

KK's Point

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 300    Accepted Submission(s): 103


Problem Description
Our lovely KK has a difficult mathematical problem:He points  N(2N105)  points on a circle,there are all different.Now he's going to connect the  N  points with each other(There are no three lines in the circle to hand over a point.).KK wants to know how many points are there in the picture(Including the dots of boundary).
 

Input
The first line of the input file contains an integer  T(1T10) , which indicates the number of test cases.

For each test case, there are one lines,includes a integer  N(2N105) ,indicating the number of dots of the polygon.
 

Output
For each test case, there are one lines,includes a integer,indicating the number of the dots.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
3 5
 

Source
 

这个题在比赛的时候没想到题解的思路,看了题解好简单,

两个方法:

方法1  找规律:

其实随便画几个就能看出规律来,

我直接说出规律了,,比如说N = 8的时候,

那么结果就是:

S1 = 1 + 2 + 3 + 4 + 5

S2 = 2 + 4 + 6 + 8

S3 = 3 + 6 + 9

S4 = 4 + 8

S5 = 5

S1 + S2 +... + S5 在加上N,就是结果!

规律很明显,很容易敲出代码了!

#include<iostream>
#include<cstdio>
#include<set>
#include<map>
#include<vector>
#include<cstring>
#include<string>
#include<sstream>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<cstdlib>
#define mem(x) memset(x,0,sizeof(x));
#define mem1(x) memset(x,-1,sizeof(x));
using namespace std;
const int maxn = 1000 + 10;
const int maxt = 75 + 10;
const double eps = 1e-8;
const int INF = 1e8;
const double pi = acos(-1.0);
typedef long long ll;
typedef unsigned long long llu;
int main()
{
    int n,T;
    cin >> T;
    while(T--){
        cin >> n;
        llu num = n-3;
        llu sum = n;
        for (int i = 1; i <= n-2; ++i){
            sum += num*i+num*(num-1)/2*i;
            num--;
        }
        cout << sum << endl;
    }
    return 0;
}

方法:(题解方法)

先不考虑在圆上的点,一共有N个点,那么里面有几个四边形,就有几个交点,比如说N = 4,就只能构成一个四边形,所以里面有1个交点加上圆上4个正好5.

为什么这么想可以呢,因为题目保证不会有三边交于一点,那么不就是四边形的对角线的交点吗,所以说有几个四边形就有几个交点。

所以答案是C N 4 + N;



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值