Exponentiation
Time Limit: 500MS | Memory Limit: 10000K | |
Total Submissions: 157596 | Accepted: 38369 |
Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
Hint
大体题意:
输入一个大数浮点数a,在输入一个整数n,计算a ^ n;
思路:
用java自带的BigDecimal 很容易求解了!
但这样算完不完善,首先会有后缀0,用BigDecimal 中stripTrailingZeros函数去掉后缀0,。
其次,如果输入时10.00 1 的话,这样会算出1E+1,会出现科学计数法,
再用toPlainString()函数去掉科学计数法。
最后一个是巨坑,舞草,这上哪去想~~~
0.123 1的话,答案是 .123,没有前导0,。。
.123 1 也是如此!
import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
public static void main(String[] args){
Scanner cin = new Scanner(System.in);
BigDecimal a;
int n;
while(cin.hasNext()){
a = cin.nextBigDecimal();
n = cin.nextInt();
String ans = a.pow(n).stripTrailingZeros().toPlainString();
if(ans.charAt(0) == '0')ans = ans.substring(1);
System.out.println(ans);
}
}
}