Packets

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

由大到小,依次考虑。

#include <iostream>

using namespace std;

int main()
{
    int num[7],sum;
    while(cin>>num[1]>>num[2]>>num[3]>>num[4]>>num[5]>>num[6]&&(num[6]||num[1]||num[2]||num[3]||num[4]||num[5])){
        sum=0;
        sum+=num[6]+num[5]+num[4]+num[3]/4;
        int t=num[3]%4;
        switch(t){
            case 1:num[2]-=5;num[1]-=7;sum++;break;
            case 2:num[2]-=3;num[1]-=6;sum++;break;
            case 3:num[2]-=1;num[1]-=5;sum++;break;
        }
        num[1]-=11*num[5];
        num[2]-=5*num[4];
        if(num[2]<=0) num[1]+=num[2]*4;
        else {
            sum+=num[2]/9;
            num[2]%=9;
            if(num[2]){sum++;num[1]-=36-4*num[2];}
        }
        if(num[1]>0) {
            sum+=num[1]/36;
            num[1]%=36;
            if(num[1]) sum++;
        }
        cout << sum << endl;
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Softnet packets(软身网络包)是一种网络传输中的数据包,用于在软件层面对网络数据进行处理和传输。Softnet packets的概念是建立在软件定义网络(Software Defined Networking,SDN)的基础上的,即将网络功能和控制从传统的硬件设备中分离出来,通过软件来实现对网络的管理和控制。 Softnet packets的处理方式相对于传统的硬件处理方式更加灵活和可编程。它可以通过编写相应的软件程序来定义和修改网络流量的路由、转发、过滤等行为,满足不同的网络需求和应用场景。与此同时,Softnet packets还可以根据网络负载和性能的优化策略,动态地分配网络资源,提高网络的吞吐量和性能。 Softnet packets的优势在于其灵活性和可扩展性。通过软件定义的方式,网络管理人员可以更加精确地配置和管理网络流量,实现对网络的精细化控制。同时,Softnet packets的虚拟化特性也使得网络资源的使用更加高效,节约了成本和能源。此外,软件定义的网络还可以与其他技术和系统相结合,例如网络功能虚拟化(Network Function Virtualization,NFV)和云计算,实现更加智能和高效的网络管理和应用部署。 总之,Softnet packets是一种通过软件定义网络来处理和传输数据的方式,具有灵活性、可编程性和可扩展性的优势。它可以实现对网络流量的精细化控制,优化网络资源的使用,提高网络性能和吞吐量,为网络管理和应用部署带来了更大的便利和效益。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值