poj 1017 Packets 装箱问题(贪心)

Packets

Poj 1017 Packets

Description

 

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

Central Europe 1996

 

解题思路:

有一些高度都相同为h的箱子,现在有1*1,2*2,3*3,4*4,5*5,6*6的大小,然后把他们都装在6*6*h大小的箱子中。输出最少需要多少个箱子。首先我们要知道对于6*6的箱子,一次只能装一个,而且没有空余位置。对于5*5的一次也只能装一个,但是会空出11个1*1的位置出来。4*4的箱子也是一次只能装一个,会空出来5个2*2的位置来。而对于3*3的箱子,一次能最多装4个。

//from:poj 1017
//time:2017.11.5
#include <stdio.h>

int main()
{
	int a,b,c,d,e,f;
	int sum,x,y;
	int u[4]={0,5,3,1};//表示在装了3*3的箱子之后还能装多少个2*2的箱子
	while(scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f)!=EOF)
	{
		if(a==0&&b==0&&c==0&&d==0&&e==0&&f==0)
			break;
		sum=f+e+d+(c+3)/4;//这些是必须要单独装一个箱子里的。 
		x=5*d+u[c%4];	//这里表示的是前面必须单独一个箱子之后,空余位置可以装x个2*2的箱子 
		if(b>x)		 
			sum+=(b-x+8)/9;	//如果空余的位置不够用的话就需要重新装一个箱子
		y=36*sum-36*f-25*e-16*d-9*c-4*b; 
		if(a>y)
			sum+=(a-y+35)/36;//前面所有箱子装完之后能空出的1*1的位置y 
		printf("%d\n",sum);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值