007:Aggressive cows

描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.


课上的例题。现将stalls坐标排序,然后在1~max(X i)/C中二分查找尝试最近距离是否可行(若不行则进入左子区间二分,若行则进入右子区间二分),最终复杂度nlog(n)。

要注意最后有可能ans得减一,因为实现二分的过程中有可能在更新完ans后发现它其实是无法满足的。用最终的remain来判断循环终止时ans是否qualify即可。或许也能通过不输出ans而输出左右来解决这个问题,但我懒得想了而且我觉得用上述方法思想比较自然。


#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
    int N, C;
    scanf("%d%d", &N, &C);
    int location[N];
    for (int i = 0; i < N; i++)
        scanf("%d", &location[i]);
    sort(location, location + N);

    int left = 1, right = location[N - 1] / C, ans, remain;
    while (left <= right)
    {
        ans = left + (right - left) / 2;
        int prev = location[0];
        remain = C - 1;
        for (int i = 1; i < N && remain; i++)
        {
            if (location[i] - prev >= ans)
            {
                remain--;
                prev = location[i];
            }
        }
        if (remain)
            right = ans - 1;
        else
            left = ans + 1;
    }
    if (remain)
        ans--;
    printf("%d", ans);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值