[POJ](3258)River Hopscotch ---二分查找+贪心(查找+贪心)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15398 Accepted: 6510

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).


解题新知:
①题意:农夫要锻炼他的牛的跳跃能力,现在有一条河,长度为L,起点为0,终点为L.(这里我们把这条河当做一个数轴)。然后给你N块石头,他们与起点的距离为Di,然后现在问你,农夫为了锻炼他的牛的跳跃能力,拿走M块石头,怎么样使得剩下的石头中最近的两块石头,距离最大(即题中output中的the maximum of the shortest distance a cow has to jump after removing M rocks).有事一个最大化最小值的问题(类似于POJ2456)

②思路:这道题几乎和POJ2456一模一样,我们就用二分+贪心的思想来做~

AC代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#define INF 1000000005
typedef long long LL;
using namespace std;
int L,n,m;
long long x[100005];
bool check(LL d)
{
    int cnt=1;
    int now=x[0];
    for(int i=1;i<=n+1;i++)
    {
        if(x[i]-now>=d)
        {
            cnt++;
            now=x[i];
        }
        if(cnt>=m)
            return true;
    }
    return false;
}
void bSearch()
{
    LL l=0;
    LL r=INF;
    LL mid;
    while(r-l>1)
    {
        mid=(l+r)/2;
        if(check(mid)) l=mid;
        else  r=mid;
    }
    printf("%lld\n",l);//最终满足题意时,一定是满足条件的,所以要求的d(mid)被赋给了l,那么我们输入l即可
}
int main()
{
    while(scanf("%d %d %d",&L,&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%lld",&x[i+1]);
        x[0]=0;
        x[n+1]=L;
        sort(x,x+n+2);
        m=n+2-m;
        bSearch();
    }
    return 0;
}




转载于:https://www.cnblogs.com/WangMeow/p/7535957.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值