2018年实训周作业——二分+贪心_POJ 3258 C - River Hopscotch

10 篇文章 0 订阅
6 篇文章 0 订阅

River Hopscotch

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21433 Accepted: 8894
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2…N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input

25 5 2
2
14
11
21
17
Sample Output

4
Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
Source

USACO 2006 December Silver

题解:这个是从长为L的河中有N个石头,数组中存的是石头到河岸的位置,拿走M个石头,使得最后石头间的最小值是最大的,求最大的最小值。换句话说就是最大化最小值并输出。
一开始,并不理解为什么这个题可以用二分,为什么是最大化最小值,读了好多博客,也很感谢大佬给我讲了好几遍。其实找个例子就好啦。
假如我现在取mid值是L那么大,那是不是相当于拿走了所有的石头,说明mid值取大了,假如我取最小值,也就是最近的那个石头离河的距离,那是不是相当于一块石头也不需要拿,说明mid值取小了。以上就是两个极端的情况,现在就是二分这个区间,找到最合适的mid值,需要注意的是,找到一个较小的mid值的时候,不一定是最大的,我们需要向后再找一个,看是不是还存在满足题意的比这个更大的mid值,总之输出的是最大的mid。
我的代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int L,n,m;
int num[1000010];
int jugde(int mid){
    int cur=0;//现在所在的位置
    int sum=0;//sum记录的是跳过可以拿的石头剩下的石头的个数
    for(int i=0;i<n;i++)
    {
        if(num[i]-cur<mid)   //如果差值比mid的值小,直接跳过,说明这个石头是可以被拿的
            continue;
        else                 //否则的话计数加1,剩下的石头个数加1,当前cur的值随之改变
        {
            sum++;
            cur = num[i];
            if(L-num[i]<mid)  //如果这个点到河岸的距离小于mid,可以直接上岸
            break;
        }
    }
    if(sum>=n-m)     //如果余下的石头多了,说明mid值取大了,这时原函数中l指针向后加一,即l = mid +1;
        return 1;
    return 0;
}
//主函数
int main()
{
    while(~scanf("%d %d %d",&L,&n,&m))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        sort(num,num+n);
        int l=0;
        int r=L;
        int ans=0;
        while(l<=r){
            int mid=(l+r)/2;//二分牛每次走的最小距离
            if(jugde(mid)==1){
                ans=mid;
                l=mid+1;   //mid找小了,区间左端点加一
            }
            else{
                r=mid-1;   //mid找大了,区间右端点减一
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值