POJ 3258-River Hopscotch(二分+贪心)

A - River Hopscotch
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Difrom the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M
Lines 2..  N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:
从N块石头中移除M块,使得间距最小值最大。


AC代码:

<pre name="code" class="cpp">#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<map>
#include<set>

using namespace std;
typedef long long ll;
#define T 100000+50
#define inf 0x3f3f3f3f

int L,N,M;
int a[T];
/*
这题之所以能够结合贪心来做是因为,首尾是不能删除的。
所以如果从左到右发现了小于距离d的话,必然是不符合的
一定要删掉。
*/
bool slove(int x)
{
	int last = 0,cur;
	for(int i=1;i<N-M;++i){//进行N-M个数的选择
		cur = last +1;
		/*
		当cur的距离与last距离小于x时,都是不能要的,要
		了就不符合最小距离是最大的了
		*/
		while(cur<N&&a[cur]-a[last]<x)cur++;
		if(cur == N)return false;
		last = cur;
	}
	return true;
}

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int i,j,k;
	while(~scanf("%d%d%d",&L,&N,&M))
	{
		for(i=1;i<=N;++i){
			scanf("%d",&a[i]);
		}
		a[0] = 0;
		a[++N] = L;
		sort(a,a+N);
		int lc=0,rc=L,mid,ans;
		/*
		左边能够小于等于右边,是由一开始的【lc,rc】区间
		确定的,因为两个都是闭区间,所以在结束的条件上也应该
		是闭区间来的,所以lc<=rc。
		*/
		while(lc<=rc)
		{
			mid = (lc+rc)/2;//二分区间的中间值
			if(slove(mid)){
				/*
				如果mid符合条件,即是符合的一个答案
				所以之后就要在【mid+1,rc】区间找是否
				存在一个比mid还大的符合条件的答案。
				*/
				ans = mid;
				lc = mid +1;
			}
			else {
				//若是mid不符合,即是答案太大了,要缩小范围
				rc = mid -1;
			}
		}
		printf("%d\n",ans);
	}

	return 0;
}


 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值