C - Running Median HDU - 3282

该博客介绍了如何利用大根堆和小根堆来实现实时计算序列中奇数位置元素的中位数。代码示例展示了在C++中如何读取输入数据,维护两个堆,确保小根堆始终包含中位数,并在满足条件时输出中位数。这种方法适用于处理大量整数数据并快速获取中位数的场景。
摘要由CSDN通过智能技术生成

Day2—C

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed.
The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space.
The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3

题意:给你n个数,当数的数量是奇数的时候就输出它们的中位数

思路:维护一个大根堆一个小根堆,小根堆里面放的是大于等于中位数的数,大根堆里面放的是比中位数小的数,小顶堆的top()肯定就是中位数.

代码如下:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>

typedef long long ll;

using namespace std;

priority_queue<int> qd;
priority_queue<int,vector<int>,greater<int> > qx;
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int x,n;
		scanf("%d%d",&x,&n);
		int nn;
		if(n&1){
			nn=n/2+1;
		}
		else{
			nn=n/2;
		}
		printf("%d %d\n",x,nn);
		while(!qx.empty()){
			qx.pop();
		}
		while(!qd.empty()){
			qd.pop();
		}
		int cnt=0;
		for(int i=1;i<=n;i++){
			scanf("%d",&x);
			if(qx.size()==0){
				qx.push(x);
			}
			else{
				if(x>qx.top()){
					qx.push(x);
				}
				else{
					qd.push(x);
				}
			}
			while(qx.size()!=qd.size()&&qx.size()!=qd.size()+1){
				if(qd.size()>qx.size()){
					qx.push(qd.top());
					qd.pop();
				}
				else{
					qd.push(qx.top());
					qx.pop();
				}
			}
			if(i%2){
				cnt++;
				if(cnt%10==0||i==n){
					printf("%d\n",qx.top());
				}
				else{
					printf("%d ",qx.top());
				}
			}
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值