1031. Hello World for U (20)
时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h d e l l r lowoThat is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:helloworld!Sample Output:
h ! e d l l lowor
#include <iostream>
#include <string>
using namespace std;
int main(){
string a;
while(cin>>a){
int n=a.size();
int row=(n+2)/3;
int sp=n-2*row;
int i,j;
for(i=0;i<row-1;i++){
cout<<a[i];
for(j=0;j<sp;j++){
cout<<" ";
}
cout<<a[n-1-i]<<endl;
}
sp=sp+2;
for(;sp>0;sp--){
cout<<a[i];
i++;
}
}
return 0;
}