POJ 1003

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source


#include <iostream>      //刚接触算法,想在博客上记录下自己的POJ历程(虽然刚开始刷)
using namespace std;
//224K 16MS
const int size = 300;

//快速排序
void Qsort(int a[], int low, int high)
{
	if (low >= high)
	{
		return;
	}
	int first = low;
	int last = high;
	int key = a[first];/*用字表的第一个记录作为枢轴*/

	while (first < last)
	{
		while (first < last && a[last] >= key)
		{
			--last;
		}

		a[first] = a[last];/*将比第一个小的移到低端*/

		while (first < last && a[first] <= key)
		{
			++first;
		}

		a[last] = a[first];
		/*将比第一个大的移到高端*/
	}
	a[first] = key;/*枢轴记录到位*/
	Qsort(a, low, first - 1);
	Qsort(a, first + 1, high);
}
int main()
{
	float c[100];
	for (int i = 0; i < 100; i++)
	{
		  std::cin >> c[i];
		  if (c[i] == 0.00)
			  break;
	}
	for (int i = 0; i < 100; i++)
	{
		float n;
		float sum;
		 int t[size];
		for (int j = 0; j < size; j++)
		{
			t[j] = 300;
		}
		int s;
		for (n = 2.0,s=0, sum = 0.00; n<size; n++,s++)
		{
			sum = sum + 1/n;
			float x = sum - c[i];
			if(x>0)
			{
				t[s] = int(n-1);
			}
		}
		Qsort(t, 0, sizeof(t) / sizeof(t[0]) - 1);

		if (c[i] == 0.00)
		{
			break;
		}
		if (c[i] != 0.00)
		{
			cout << t[0] << " card(s)" << endl;
		}
	}
	return 0;
}

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值