hdu 4952 Number Transformation--2014 Multi-University Training Contest 8

79 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4952


Number Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 342    Accepted Submission(s): 156


Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
  
  
2520 10 2520 20 0 0
 

Sample Output
  
  
Case #1: 2520 Case #2: 2600
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   4955  4954  4953  4951  4949 
 

Statistic |  Submit |  Discuss |  Note



(i+1)*_x>=i*x   可得 _x>=x-x/(i+1).即 _x=x-[x/(i+1)],所以当x<i+1时,_x值的值就不会发生变化了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<bitset>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<cstdlib>
using namespace std;
#define CLR(A) memset(A,0,sizeof(A))
typedef long long ll;
int main(){
    ll n,k;
    int ncase=0;
    while(cin>>n>>k&&(n+k)){
         ll tmp=n;
         for(ll i=2;i<=k;i++){
            tmp=tmp-tmp/i;
            if(tmp<i) break;
         }
         printf("Case #%d: %I64d\n",++ncase,tmp*k);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值