题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4961
Boring Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 95 Accepted Submission(s): 49
Problem Description
Number theory is interesting, while this problem is boring.
Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.
Given an integer sequence, your task is to calculate its boring sum.
Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.
Given an integer sequence, your task is to calculate its boring sum.
Input
The input contains multiple test cases.
Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).
The input is terminated by n = 0.
Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).
The input is terminated by n = 0.
Output
Output the answer in a line.
Sample Input
5 1 4 2 3 9 0
Sample Output
136HintIn the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
Source
Recommend
#include <stdio.h>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <bitset>
#include <cstdlib>
#define CLR(A) memset(A,0,sizeof(A))
#define MAX(a,b) ((a)>(b)?(a):(b))
#define MIN(a,b) ((a)<(b)?(a):(b))
#define ABS(a,b) ((a)>=0?(a):(-a))
using namespace std;
vector<set<int> > VEC(100100);
int data[100100],b[100100],c[100100],datar[100100];
int main()
{
int n;
while(scanf("%d", &n),n)
{
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=0;i<=100000;i++)
VEC[i].clear();
for(int i=1;i<=n;i++){
scanf("%d",&data[i]);
VEC[data[i]].insert(i);
b[i]=data[i];
c[i]=data[i];
}
for(int i=1;i<=n;i++){
if(b[i]==1 && i-1>0) b[i]=data[i-1];
if(c[i]==1 && i+1<=n) c[i]=data[i+1];
}
for(int i=1;i<=n;i++){
for(int j=2;j*j<=data[i];j++){
if(data[i]%j==0){
int tmp=j,id;
if(VEC[tmp].size()!=0){
id=*(VEC[tmp].lower_bound(i));
if(VEC[tmp].lower_bound(i)!=VEC[tmp].end())
b[id]=data[i];
}
tmp=data[i]/j;
if(VEC[tmp].size()!=0){
id=*(VEC[tmp].lower_bound(i));
if(VEC[tmp].lower_bound(i)!=VEC[tmp].end())
b[id]=data[i];
}
}
}
}
for(int i=n;i>=1;i--){
for(int j=2;j*j<=data[i];j++){
if(data[i]%j==0){
int tmp=j,id;
set<int>::iterator p;
if(VEC[tmp].size()!=0){
p=VEC[tmp].upper_bound(i);
if(p!=VEC[tmp].begin()){
p--;id=*p;
c[id]=data[i];
}
}
tmp=data[i]/j;
if(VEC[tmp].size()!=0){
p=VEC[tmp].upper_bound(i);
if(p!=VEC[tmp].begin()){
p--;id=*p;
c[id]=data[i];
}
}
}
}
}
long long ans=0;
for(int i=1;i<=n;i++){
ans+=((long long)b[i])*((long long)c[i]);
}
cout<<ans<<endl;
}
return 0;
}