hdu 5045 Contest--2014acm上海赛区网络赛

79 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5045


Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 171    Accepted Submission(s): 60


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. 

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. 

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. 

For each problem, each student has a certain probability that correct solve. If the i th student solve the j th problem, the probability of correct solve is P ij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. 

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the j th number in the i th line is P ij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
  
  
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
  
  
Case #1: 2.20000
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5052  5051  5049  5048  5046 
 

Statistic |  Submit |  Discuss |  Note


可以转换成最小费用流问题,果断贴模板上去了。。。


//#pragma comment(linker, "/STACK:36777216")
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;
#define typef int
#define typec double
const typef inff = 0x3f3f3f3f;
const typec infc = 0x3f3f3f3f;
const int E=1010;
const int N=100;
class network
{
public:
    int nv, ne, pnt[E], nxt[E];
    int vis[N], que[N], head[N], pv[N], pe[N];
    typec cost, dis[E], d[N];typef flow, cap[E];
    void addedge(int u, int v, typef c, typec w) {
        pnt[ne] = v; cap[ne] = c;
        dis[ne] = +w; nxt[ne] = head[u]; head[u] = ne++;
        pnt[ne] = u; cap[ne] = 0;
        dis[ne] = -w; nxt[ne] = head[v]; head[v] = ne++;
    }
    double mincost(int src, int sink) {
        int i, k, f, r; typef mxf;
        for (flow = 0, cost = 0; ; ) {
            memset(pv, -1, sizeof(pv));
            memset(vis, 0, sizeof(vis));
            for (i = 0; i < nv; ++i) d[i] = infc;
            d[src] = 0; pv[src] = src; vis[src] = 1;
            for (f = 0, r = 1, que[0] = src; r != f; ) {
                i = que[f++]; vis[i] = 0;
                if (N == f) f = 0;
                for (k = head[i]; k != -1; k = nxt[k])
                if(cap[k] && dis[k]+d[i] < d[pnt[k]]){
                    d[pnt[k]] = dis[k] + d[i];
                    if (0 == vis[pnt[k]]) {
                        vis[pnt[k]] = 1;
                        que[r++] = pnt[k];
                        if (N == r) r = 0;
                    }
                    pv[pnt[k]]=i; pe[pnt[k]]=k;
                }
            }
            if (-1 == pv[sink]) break;
            for (k = sink, mxf = inff; k != src; k = pv[k])
                if (cap[pe[k]] < mxf) mxf = cap[pe[k]];
                    flow += mxf; cost += d[sink] * mxf;
            for (k = sink; k != src; k = pv[k]) {
                cap[pe[k]] -= mxf; cap[pe[k] ^ 1] += mxf;
            }
        }
        return cost;
    }
    void build(int v) {
        nv = v; ne = 0;
        memset(head, -1, sizeof(head));
    }
};network g;
int m,n; //n 人数   m题数
double So[20][1010];
double solve(int x,int y){
  //  cout<<"ST SOLVE"<<endl;
    double ret=0;
    int Pro=y-x+1;
    int nv=n+Pro+1;
 //   cout<<"Pro="<<Pro<<' '<<"nv="<<nv<<' '<<"n="<<n<<endl;
    g.build(nv+1);
    for(int i=1;i<=n;i++)
        g.addedge(0,i,1,0);
    for(int i=n+1;i<=n+Pro;i++)
        g.addedge(i,nv,1,0);
    for(int i=1;i<=n;i++)
        for(int j=n+1;j<=n+Pro;j++){
            g.addedge(i,j,1,-So[i][j-n-1+x]);
        }
    ret=g.mincost(0,nv);
    return ret;
}
int main(){

    #ifdef ONLINE_JUDGE
    #else
        freopen("in.txt","r",stdin);
    #endif
    int T,kase=0;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%lf",&So[i][j]);
            }
        }
        double ans=0.0;int t=0;
        for(int i=1;i<=m;i+=n){
            ans+=solve(i,min(m,i+n-1));
        }
        printf("Case #%d: %.5lf\n",++kase,-ans);
    }
    return 0;
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值