K - 迷宫问题



K - 迷宫问题
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
POJ 3984
Description
定义一个二维数组: 


int maze[5][5] = {


 0, 1, 0, 0, 0,


 0, 1, 0, 1, 0,


 0, 0, 0, 0, 0,


 0, 1, 1, 1, 0,


 0, 0, 0, 1, 0,


};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)

(4, 4)


#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

typedef struct pos{
    int x, y;
}pos;
int maze[5][5], rot[5][5];
int d[4][2] = { {0,1},{0,-1},{1,0},{-1,0} };
bool judge(pos x)
{
    if(x.x<0||x.x>4 || x.y<0||x.y>4 || maze[x.x][x.y]!=0)  return false;
    if(rot[x.x][x.y]!=-1)   return false;
    return true;
}
void prin(int x, int y)
{
    if(x==0 && y==0){ printf("(%d, %d)\n", 0, 0); return;}
    if(rot[x][y]==0)     { prin(x, y-1); }
    else if(rot[x][y]==1){ prin(x, y+1); }
    else if(rot[x][y]==2){ prin(x-1, y); }
    else if(rot[x][y]==3){ prin(x+1, y); }
    printf("(%d, %d)\n", x, y);
}
void bfs()
{
    pos now, next;
    queue<pos>Q;
    now.x=0; now.y=0;
    Q.push(now);
    while( !Q.empty() ){
        now=Q.front(); Q.pop();
        if(now.x==4 && now.y==4){ prin(4,4);  return;}
        for(int i=0; i<4; i++){
            next.x=now.x+d[i][0]; next.y=now.y+d[i][1];
            if( judge(next) ){
                rot[next.x][next.y]=i;
                Q.push(next);
            }
        }
    }
}

int main()
{
    for(int i=0; i<5; i++)
        for(int j=0; j<5; j++)
            scanf("%d", &maze[i][j]);
    memset(rot, -1, sizeof(rot));
    bfs();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值