迷宫问题
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 28881 | Accepted: 16636 |
Description
定义一个二维数组:
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, };
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0
Sample Output
(0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)
真TM水;
AC代码:
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int mapp[10][10] ;
bool vis[10][10];
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
struct Node{
int x;
int y;
int step;//设置步数标记,方便输出检测
};
bool judge(int x,int y){
if(x<0||y<0||y>4||x>4||mapp[x][y]||vis[x][y]){
return false;
}
return true;
}
void bfs(int x,int y){
memset(vis,false,sizeof(vis));
vis[0][0]=true;
Node pr;
pr.step=0;
pr.x=x;
pr.y=y;
queue<Node>Q;
queue<Node>qq;//存路径
qq.push(pr);
Q.push(pr);
while(!Q.empty()){
pr=Q.front();
Q.pop();
if(pr.x==4&&pr.y==4){
break ;
}
for(int i=0;i<4;i++){
Node pn;
pn.x=pr.x+fx[i];
pn.y=pr.y+fy[i];
if(judge(pn.x,pn.y)){
pn.step=pr.step+1;
vis[pn.x][pn.y]=true;
Q.push(pn);
qq.push(pn);
}
}
}
int i=0;
while(!qq.empty()){
Node k;
k=qq.front();
qq.pop();
if(k.step==i){//输出检测
cout<<"("<<k.x<<", "<<k.y<<")"<<endl;
i++;
}
}
}
int main(){
for(int i=0;i<5;i++){
for(int j=0;j<5;j++)
cin>>mapp[i][j];
}
bfs(0,0);
return 0;
}